function foo()
{
}

2010年10月8日金曜日

rails3の準備

ruby 1.8.6/Rails 2.0.2がインストールされているWindows XPにruby 1.9.x/Rails 3.xを共存させる。

参考ページ

1. Pik0.2.8.msiをダウンロード&インストール

2. 既にインストールされているruby 1.8.6をPikに組み込む
> pik add


3. Ruby1.9.2をインストールする。
3.1 pikで確認
> pik list -r
1.9.2-p0: http://rubyforge.org/frs/download.php/72160/ruby-1.9.2-p0-i386-mingw32.7z
1.9.2-rc1: http://rubyforge.org/frs/download.php/71498/ruby-1.9.2-rc1-i386-mingw32.7z
1.9.2dev-preview3-1: http://rubyforge.org/frs/download.php/71175/ruby-1.9.2dev-preview3-i386-mingw32-1.7z


3.2 1.9.2-p0をインストール
> pik install ruby -v 1.9.2-p0


3.3 確認する
> pik list


4. 1.9.2に切り替える
> pik use 192


5. Rails3をインストール
> gem install rails --version ">= 3.0"


6. SQLite本体とdllをDownload Pageからダウンロードする。解凍して同じフォルダに入れて、PATHを通しておく(今回はとりあえずC:¥sqlite3を用意してそこに入れた)。

7. 再起動

pik use 192 ... Rails3
pik use 186 ... Rails2
に切り替わる。便利だ。

0 件のコメント:

コメントを投稿